Função SE com mais de sete condições!

Aninhando funções

Quando queremos inserir uma função dentro da outra, como no caso de queremos colocar várias condições Se dentro de uma mesma fórmula, chamamos isto de ANINHAMENTO DE FUNÇÕES.

A versão 2013 permite 64 aninhamentos (poderiam ser 64 SE…).

A importância da Lógica

Antes de você ir montar essa sequência de SE, é importante saber que lógica deveria seguir, porque se olharmos somente para a necessidade de uma função SE, podemos focar no meio de resolver o problema, e não no problema em si.

Vamos supor que você queira que ela analise uma célula que tem nomes de meses e retorne seus respectivos números de ordem, mas os meses do ano são 12 e a SE oferece análise para 7 condições somente, e agora?

No exemplo a SE vai analisar o que estiver na célula “I1″.

Na célula que você quer o resultado você digita a fórmula abaixo:

=SE(I$1=”JANEIRO”;1;SE(I$1=”FEVEREIRO”;2;SE(I$1=”MARÇO”;3;SE(I$1=”ABRIL”;4;SE(I$1=”MAIO”;5;SE(I$1=”JUNHO”;6;

SE(I$1=”JULHO”;7;SE(I$1=”AGOSTO”;8;SE(I$1=”SETEMBRO”;9;SE(I$1=”OUTUBRO”;10;SE(I$1=”NOVEMBRO”;11;SE(I$1=”DEZEMBRO”;12;”não encontrado”))))))))))))

 

Basicamente dependendo do mês, queremos trazer uma informação distinta.


Está Gostando Do Artigo?

Assine Nossa Newsletter E Mantenha-Se Atualizado/a Com Dicas De Excel & Dashboards

Sua Privacidade Está Garantida. Não Compartilhamos Seu E-Mail.


 

A surpresa

Considerando a necessidade, NÃO DEVEMOS USAR A FUNÇÃO SE!

Imagina uma função deste tamanho! A chance de dar erro é enorme, sem contar o limite de 64 aninhamentos. Na fórmula acima fizemos 12, imagina o tamanho da fórmula se usarmos 64 SE!

A melhor situação para isto é a função PROCV (também daria para usar a ESCOLHER, dependendo do caso).

Veja o exemplo a seguir:

blog

Note que na função PROCV estamos buscando o ítem digitado da I1 (tal como no exemplo da função SE). Daí selecionamos um intervalo onde digitamos os resultados esperados para cada ítem (intervalo entre H7 e I18), o número 2 representa que queremos a segunda coluna do intervalo (neste caso o número do mês). O FALSO (ou 0) diz que a função deve procurar exatamente o que foi digitado, sem procurar nada que ela considere aproximado.

Tem mais algumas coisas sobre PROCV aqui e aqui.

Então, tome cuidado quando tiver um problema a resolver, não pense “como colocar diversos SE”, e sim “como criar uma função que analise dezenas de condições”.

O que achou? Já se deparou com algo assim? Como fez?

Comente aí embaixo!

 

Fabio Vianna
Siga-Me

Fabio Vianna

Modela planilhas deste 1994 e ministra treinamentos desde 1997.
Especialista em Modelagem Profissional de Planilhas, incluindo Dashboards no Excel.
Fabio Vianna
Siga-Me

Últimos posts por Fabio Vianna (exibir todos)

  • alisson rocha

    o que eu posso dizer? Meus parabéns por este artigo, resolveu o problema q eu estava há 4 horas tentando solucionar, li vários artigos, mas este q resolveu meu problema.

    valeu!!!!!!!!!!

  • Marcos Roberto Gatto

    Estão de parabéns pelo site.
    Vocês são práticos e realistas.
    Parabéns a todos!

  • Edilson Toniolo

    parabéns!! estava ha horas tentando achar uma solução!!!

  • Assis

    Uma outra forma é usar função se encadeada, onde cada condição será o valor falso da outra condição
    Ex: Se A1 for entre 100 e 50 B1 será “C”, se for entre menor que 49 será “B”, se for igual a 0 será “A”.
    =SE(A1=0;”A”;SE(A1<50;”B”;SE(A1<100;”C”;””)))

  • VIVIANY FIORI

    Muito obrigada vc conhece muito cara. valeu

  • viviany

    fiz como seu exemplo mas não consegui que uma “puxasse” os dados da outra só aparece as condições da primeira o que posso ter feito de errado?

  • Victor

    Muito obrigado, sensacional o artigo

  • Duarte

    Muito boa dica, obrigado

  • http://biotecconsultoria.com.br Roberto Dini

    Leandro A. R. Barbosa, você me tirou de uma “enrascada” muito grande. Ótima dica essa sua. Deu certo! Muito obrigado!

  • http://biotecconsultoria.com.br Roberto Dini

    Este site é muito bom! Por favor, quem puder, colcabore com as sugestões. Eu sou um aprendiz e só posso me contemplar pela existência dele. Obrigado!

  • Gilvan

    Olá Amigos,

    O trabalho de voçes está muito bom, parabéns a todos.

    Gilvan Sousa

  • Antonio Francisco

    Kra valeu mesmo a dias eu andava atrás desta função, obrigado!

  • JQueiroz

    Bem pensado!!! eu uso o =PROCV ou =PROCH

  • Diego

    Estava pesquisando este assunto e achei uma outra forma o CONCATENAR

    http://www.planilhao.com/artigo/artigos.php?arte=zxqwr0071

    ai o link caso queiram dar uma olhada

  • Walton

    Muito boa a dica!Parabéns ao colega!

  • luana

    adorei essa resposta é perfeita
    eu ado0o0o0o0oro esse site

  • Carlos Fernando

    Valeu pessoal, vcs me ajudaram muito.
    Estava a +/- 3:00 procurando esta fórmula.
    Este site realmente foi muito útil.
    Obrigado

Sabia Que Este Gráfico Possui 13 Erros?

Fechar

Baixe Grátis O PDF

Baixe Grátis PDF Com a Explicação Dos 13 Erros E Melhore Seus Gráficos Em Alguns Cliques!
Receba Grátis Também Em Seu Email Tutoriais De Gráficos Profissionais, Apresentados por Fábio Vianna

nunca compartilharemos seu email