Pesquisando valores verticalmente numa lista utilizando a função PROCV

A função PROCV localiza um valor na primeira coluna à esquerda de uma tabela especificada e retorna o valor da mesma linha de uma coluna especificada.

Sintaxe:
PROCV(valor_procurado;matriz_tabela;num_índice_coluna;procurar_intervalo)

Valor_procurado: é o valor a localizar na primeira coluna da tabela especificada.

Matriz_tabela: duas ou mais colunas dos dados que serão procurados.

Num_índice_coluna: o número da coluna em matriz_tabela a partir do qual o valor correspondente tem de ser devolvido. Exemplo: se núm_índice_coluna for 1 devolve o valor na primeira coluna em matriz_tabela; se núm_índice_coluna for 2 devolve o valor na segunda coluna em matriz_tabela, e assim por diante.

Procurar_intervalo: Um valor lógico que especifica se deseja que o PROCV localize uma correspondência exata ou uma correspondência aproximada. Pode ser VERDADEIRO ou FALSO.

Se VERDADEIRO ou omisso, é devolvida uma correspondência exata ou aproximada.
Se FALSO, o PROCV localiza apenas uma correspondência exata.

Em nosso exemplo temos uma tabela com o número de identificação de funcionários, seus respectivos nomes e cargos:

ex16

Suponhamos que a tabela seja enorme e sabemos apenas o número de identificação de um funcionário e queremos saber o seu nome. Para isso utilizamos a função PROCV.
Selecione uma célula que deseja retorna o nome procurado. Insira a seguinte função:

=PROCV(200947;B2:E5;2;FALSO). Retornará Plínio:

ex25

Descrição:
Pesquisa o número de identificação 200947, na primeira coluna da tabela especificada (B2:E5) e devolve o valor correspondente na mesma linha da segunda coluna.

Fabio Vianna
Siga-Me

Fabio Vianna

Modela planilhas deste 1994 e ministra treinamentos desde 1997.
Especialista em Modelagem Profissional de Planilhas, incluindo Dashboards no Excel.
Fabio Vianna
Siga-Me

Últimos posts por Fabio Vianna (exibir todos)

  • Alex

    Olá Luigi !
    Antes de mais nada, agradeço e muito pelas informações aqui desta página. Agora eu gostaria que me esclarecesse uma dúvida, se possível.
    Tenho uma planilha enorme com vários valores em percentual em uma coluna outros valores ao lado (números inteiros). Tentando apenas um pequeno exemplo, vamos imaginar a primeira coluna (percentual) começando na célula K25, contendo os números: “0,10”, “0,20”, “0,40”, “5,00”, “31,01”, “0,55” e “10,20”. Na coluna ao lado (começando em L25) têm os valores: “2”, “7”, “78”, “6”, “36”, “31” e “20” e tenho que estou tentando fazer a relação do maior valor da coluna percentual com a outra coluna através da fórmula: “=PROC(MÁXIMO(K25:K31);K25:L31”, só que, em vez da mesma me retornar o valor 36 (que seria o correspondente para os 36% da coluna de percentual), ela me retorna o valor “20”. Poderia tentar me dizer o que há de errado ?
    Desde já agradeço a sua atenção, Alex.

  • Alex

    Perdão e corrigindo:
    “…em vez da mesma me retornar o valor 36 (que seria o correspondente para os 31,01% da coluna de percentual), ela me retorna o valor “20″…

  • https://www.fabiovianna.com.brsite adm_dicas_excel

    Olá Alex. Obrigado pelos elogios. Insira a seguinte fórmula:

    =PROCV(MÁXIMO(K25:K31);K25:L31;2;0)

    Lembrando que o 0 significa a correspondencia aproximada.

  • Ana

    Muito Obrigada…
    Esse site me ajudou a entender
    tudo que precisava,sem dúvida de
    nada…

    Muito Obrigada

    Atenciosamente:
    Ana

  • Pingback: Gráfico Interativo no Excel Com A Situação Dos Mananciais()

Sabia Que Este Gráfico Possui 13 Erros?

Fechar

Baixe Grátis O PDF

Baixe Grátis PDF Com a Explicação Dos 13 Erros E Melhore Seus Gráficos Em Alguns Cliques!
Receba Grátis Também Em Seu Email Tutoriais De Gráficos Profissionais, Apresentados por Fábio Vianna

nunca compartilharemos seu email