No Excel você pode comparar células utilizando uma fórmula de matriz, mais conhecida como array formula. Como exemplo, vamos verificar se os valores das células de A1:A5 são iguais aos valores de B1:B2. Construiremos uma função que retornará o numero de células que estão diferentes:

ex19

Para isso vamos usar as funções SOMA e SE. Digite numa outra célula a seguinte função:

=SOMA(SE(A1:A5=B1:B5;0;1))

Lembrando que após escrever a função digite Ctrl+Shift+Enter, para inserir uma fórmula de matriz.

Vamos entender a fórmula:

A função SE verifica se a coluna A1:A5 é igual a coluna B1:B5. Se verdadeira retorna 0. Se falsa retorna 1.

A Função SOMA, somará os valores que a função SE retornar. Como aplicamos uma fórmula de matriz, ela retornará os valores de cada linha que estiver igual ou diferente. Em nosso exemplo, retornará 0, pois todas a linhas estão com o mesmo valor:

ex28

Experimente colocar outros valores nas colunas:

ex34

Veja que agora a função retorna 2 pois duas linhas estão com valores diferentes (linha 2 e 5).

Comentários
Fabio Vianna
Siga-Me

Fabio Vianna

Modela planilhas deste 1994 e ministra treinamentos desde 1997.
Especialista em Modelagem Profissional de Planilhas, incluindo Dashboards no Excel.
Fabio Vianna
Siga-Me

Últimos posts por Fabio Vianna (exibir todos)

Receba nossa Agenda

Cadastre-se para receber nossa agenda de treinamentos.

Obrigado :)