Hoje iremos postar a dica do ganhador do desafio da semana passada Alessandro Wenger..achei super interessante e muito útil no dia a dia…veja:

Imagine a seguinte situação:
 
Você tem uma série de eventos (pode ser qualquer evento, por exemplo, horários de chamadas telefônicas, horários de pedidos, etc) em uma tabela e você quer saber quantos eventos ocorreram em um determinado período de tempo, por exemplo, quantos pedidos ocorreram entre as 11:00:00 e 12:00:00, quantos pedidos entre as 12:00:00 e 13:00:00 e assim por diante.
 
Existe uma fórmula, ou uma combinação de fórmulas que faz isto de maneira interessante.
 
No exemplo abaixo, temos na coluna A, todos os eventos registrados com suas respectivas horas (momento em que ocorreu o evento).
 
Então, na coluna C, eu adicionei os intervalos que eu gostaria que a planilha contasse.
 
Na coluna D, onde estão as fórmulas, temos os resultados.
 
A sintaxe da fórmula é:
 
=SOMARPRODUTO(–($A$2:$A$561>=C2);–($A$2:$A$561<C3))
 
Onde no exemplo:
 
$A$2:$A$561 é o range de dados que eu quero contar
 
C2 é o horário inicial da contagem
 
C3 é o horário final da contagem
 
Ou seja, em D2 teremos então a quantidade de eventos que ocorreram em 18/11/05 das 00:00:00 à 01:00:00, e assim por diante

image001

Alessandro Wenger

 

Caso você tenha alguma dúvida ou sugestão envie paa nós:

contato@dicasdeexcel.com.br

 

Boa noite! =)

FV

Comentários
Fabio Vianna
Siga-Me

Fabio Vianna

Modela planilhas deste 1994 e ministra treinamentos desde 1997.
Especialista em Modelagem Profissional de Planilhas, incluindo Dashboards no Excel.
Fabio Vianna
Siga-Me

Últimos posts por Fabio Vianna (exibir todos)

Receba nossa Agenda

Cadastre-se para receber nossa agenda de treinamentos.

Obrigado :)